citations

Guillaume's Avatar

Guillaume

02 Aug, 2017 09:35 AM

Hi,

I use Scrivener for my writing. When I compile footnote with a citation from MMD to latex, it appears sometimes a line break without reasons:

Mmd: [#grenier2007].
Latex: \footnote{~\citep{grenier2007}.}

or sometimes I don't know why because there's no difference, it appears:

Latex:
\footnote{

~\citep{grenier2007}.}

Can you help me?
thanks
Guillaume

  1. Support Staff 1 Posted by fletcher on 03 Aug, 2017 12:00 AM

    fletcher's Avatar

    Is this from the same outdated version of MMD as your other question? I'm not away of issues like this in remotely recent versions of MultiMarkdown.

    The Scrivener forums can help you upgrade to a more modern version of MMD, which I strongly recommend.

    Otherwise, please send a complete working example, and I can try to help find the problem.

    Fletcher

  2. 2 Posted by Guillaume Marti... on 03 Aug, 2017 09:09 AM

    Guillaume Martins's Avatar

    Hi,

    I think I’ve correctly updated MMD in Scrivener (I use the Mac support file installer). I’ve tried many things for my problem.
    It seems that when I compile MMD to Latex with MMD v5 the citations are perfects in the Latex file and with MMD v6 the problem of the line break appears.

    Moreover, the problem with the label still exist whether for MMD v5 and MMD v6.

    I’ve got still:

    \subsubsection{Lests « permanent » et « momentané »}
    \label{lests« permanent »et« momentané»}

    \subsubsection{L’eau}
    \label{l’eau}

    Which make errors when I compile in pdf file.

    Thanks for your help

    Guillaume

  3. Support Staff 3 Posted by fletcher on 03 Aug, 2017 11:30 PM

    fletcher's Avatar

    These examples are different than the previous one. You used unicode
    (UTF-8) characters, which are valid label characters in HTML-5, so they
    are not stripped out.

    You're better off working with MMD instead of around it -- use plain
    quote characters and specify the desired quotes language metadata to
    convert them to the desired rich substitutes:

    latex config: article
    quoteslanguage: french

    # Lests "permanent" et "momentané"

    ## L'eau

    Alternatively, you can manually specify labels for headers and use
    whatever characters you like in the headings:

    # Lests « permanent » et « momentané » [lestspermanent]

    ## L’eau [leau]

    Whichever you prefer.

    Fletcher

  4. 4 Posted by Guillaume Marti... on 04 Aug, 2017 08:06 AM

    Guillaume Martins's Avatar

    Hi,

    I don’t understand everything about quote language metadata, but I specified already the language in my Latex file, so it should work, no?:

    \documentclass[12pt,a4paper,twoside]{book}
    \usepackage[french]{babel}
    \usepackage[utf8]{inputenc}
    \usepackage[T1]{fontenc}

    But,as you said I specify manually the label and it works perfectly, so it’s good and easier for me.

    Thank you very much

    Guillaume

  5. Support Staff 5 Posted by fletcher on 04 Aug, 2017 10:19 PM

    fletcher's Avatar

    Metadata changes the behavior of MMD itself, so it translates plain
    quotes (e.g. "foo") into smart quotes (e.g. «foo»).

    But whichever way you prefer is the "right" way.

    F-

  6. fletcher closed this discussion on 22 Aug, 2017 01:16 AM.

  7. Guillaume Martins re-opened this discussion on 13 Nov, 2017 09:33 AM

  8. 6 Posted by Guillaume Marti... on 13 Nov, 2017 09:33 AM

    Guillaume Martins's Avatar

    Hello,

    I’ve got a problem with superscripts with isotopics elements.
    How do you make the syntax MMD to have in the pdf: 235U/238U
    When I write in MMD : ^235^U/^238^U in latex I have: \^{}235\textsuperscript{U/}238\textsuperscript{U}
    So the PDF file is: ˆ235U/238U instead of 235U/238U
    Can you help me?

    Thanks

    Guillaume

  9. Support Staff 7 Posted by fletcher on 13 Nov, 2017 12:38 PM

    fletcher's Avatar

    MMD superscripts and subscripts have to follow the main text, not precede it.

    So to do this, you would need to write the entire symbol in LaTeX.

    I'll look into whether this can be changed without causing negative effects.

    F-

  10. Support Staff 8 Posted by fletcher on 13 Nov, 2017 01:30 PM

    fletcher's Avatar

    I changed the algorithm and test examples, and didn't find any negative effects by allowing leading superscripts/subscripts. So you can do this now in the develop branch. It will be moved to the master branch for the next version update.

  11. fletcher closed this discussion on 13 Nov, 2017 01:30 PM.

  12. Guillaume Martins re-opened this discussion on 13 Nov, 2017 02:35 PM

  13. 9 Posted by Guillaume Marti... on 13 Nov, 2017 02:35 PM

    Guillaume Martins's Avatar

    Thank you for your answer, but I let you change the code and put in the develop branch because I’m not a programmer and I don’t know how I can do that. I can just tell you the bugs, not correct them.

    Guillaume

  14. Support Staff 10 Posted by fletcher on 13 Nov, 2017 02:36 PM

    fletcher's Avatar

    No -- it's in the develop branch if you download it.

    F-

  15. 11 Posted by Guillaume Marti... on 13 Nov, 2017 06:29 PM

    Guillaume Martins's Avatar

    I downloaded the 6.2.2 .dmg version, and I think I installed it. But I installed Mac installer 4.6 package. Maybe I should not. Because now I’ve got a new problem. When I compile MultiMarkdown to latex in Scrivener, in my .tex file there’s no more my input file (begin and header) and some syntax doesn’t compile in latex. I don’t know why, maybe I put a old version? It’s a problem with MMD or Scrivener?

    I really have problems each time I want update MultiMarkdown, specially with Scrivener. Because I don’t know how does it really work.

    Thanks.
    Guillaume

  16. Support Staff 12 Posted by fletcher on 13 Nov, 2017 07:08 PM

    fletcher's Avatar

    Sorry -- perhaps I didn't explain well enough. The new feature is in the development branch of the code. It has not been compiled into a new binary yet. The code itself can be downloaded and compiled if any one likes.

    As for Scrivener -- you should ask on their forums. I believe they use a rather outdated version of MMD in their project. Especially if you end up converting to LaTeX.

  17. 13 Posted by Guillaume Marti... on 14 Nov, 2017 12:53 PM

    Guillaume Martins's Avatar

    Hi,

    You explain well enough, but I don’t know how to compile the code, so, for waiting your update, I wanted to upgrade my version to 6.2.2. but I as I said I’m not a computer scientist. And each time I want to upgrade MMD, I ‘ve problems.

    So, to explain maybe better to you, the Scrivener Manuel says:

    Scrivener comes with MultiMarkdown support built in, so you don’t have to worry about installing anything extra. However, there may be times when MultiMarkdown updates in between Scrivener versions. In that case you may want to ensure that you have the latest version of MultiMarkdown installed. To ensure that Scrivener uses the most recent version of MultiMarkdown rather than the version built into Scrivener, you just have to install the new version of MultiMarkdown into either ∼/Library/Application Support/MultiMarkdown. The installer for the support package will handle placement for you.

    Your web page indicate:

    Using MultiMarkdown with Scrivener
    Scrivener <http://www.literatureandlatte.com/> is a great program for writers using Mac OS X. It includes built in support for MultiMarkdown. If you want to use MultiMarkdown 3.0 with Scrivener, you need to install the Support files in ~/Library/Application Support/MultiMarkdown. The MultiMarkdown-Support installer is available from the downloads page <http://fletcherpenney.net/multimarkdown/download/> and will install these files for you.

    So I downloaded and installed the Multimarkdown support Mac 4.6.pkg.
    It appears the file Multimarkdown in the right path (with inside the files: bin, utilities, xslt)

    Then I downloaded and installed the file Multimakdown Mac 6.2.2.dmg.

    But I don’t know where the package have been installed.
    Nothing has changed in file ~/Library/Application Support/MultiMarkdown.

    So How do I know if version 6.2.2 is really installed?
    Can you tell me how does the installation work because I really want to solve this recurrent problem.

    Sorry for the inconvenience
    Thanks

    Guillaume

  18. Support Staff 14 Posted by fletcher on 15 Nov, 2017 02:55 PM

    fletcher's Avatar

    Again -- Scrivener has not kept up with MultiMarkdown. If you need help using MultiMarkdown with Scrivener, the best place to ask is the Scrivener support forums.

    MultiMarkdown version 4 was released in early 2013. "MultiMarkdown Support" was designed for version 3 and hasn't been updated since then. So anything related to v3 is really out of date.

    MultiMarkdown v6 defaults to /usr/local/bin/multimarkdown. multimarkdown --v will tell you which version you have installed.

    ~/Library/Application Support/MultiMarkdown is not used any more.

  19. 15 Posted by Guillaume Marti... on 16 Nov, 2017 08:19 PM

    Guillaume Martins's Avatar

    Hello,

    Sorry for asking again.
    About my problem with Scrivener, MMD and Latex, I did severals tests. It seems that’s a problem with MMD version.

    So, my test:
    I installed MMD version 5.4.0.dmg. everything is ok the Latex file is perfect.
    When I install MMD version 6.2.2.dmg the problems appear.
    When I reinstalled MMD v5.4.0.dmg, it’s ok.

    Bellow the screen print:
    Scrivener with MMD v5.4.0

    And bellow with MMD V6.2.2:
      in Latex, the pink code and the input file "header and begin" have disappeared.

    It’s seems in the forum that MMD6 doesn’t take in account the html comment for raw latex code yet. Is that it?

    But I still don’t understand why in the .tex file there’s : \input{mmd-scrivcustom-footer}

    And no \input{mmd-scrivcustom-header} and \input{mmd-scrivcustom-begin-doc}

    in Scrivener, there’s the three in latex option, with MMD 5.4.0 it works, and no with MMD6.2.2.

    Furthermore, my problem with citation still here with MMD6.2.2. (and not with MMD 5.4.0)

    When I compile footnote with a citation from MMD6 to latex, it appears sometimes a line break without reasons:

    Mmdv6 : [#grenier2007].

    Latex:
    \footnote{

    ~\citep{grenier2007}.}

    Instead:
    \footnote{~\citep{grenier2007}.}

    So in the pdf file there’s a break line.
    This not happen with MMD5.4.0.

    thanks for your help
    Guillaume

  20. Support Staff 16 Posted by fletcher on 16 Nov, 2017 08:22 PM

    fletcher's Avatar

    MMD 6 works differently than MMD 5.

    Please see the MMD 6 documentation (especially the Quick Start Guide)
    for more information.

    But perhaps the more important question is what prompted you to try to
    update in the first place? If everything is working fine as is, perhaps
    you should stick with an older version of MMD until Scrivener updates to
    version 6??

    F-

  21. 17 Posted by Guillaume Marti... on 17 Nov, 2017 01:38 PM

    Guillaume Martins's Avatar

    Hi Fletcher,

    I’m sorry, but I’m just beginning to understand how Scrivener, MMD et Latex work together. It’s not really easy for me, beginner in the three software, not a computer scientist and with my poor English...
    After reading the quick start guide of MMDv6 and several exchanges with Scrivener support, It’s a little clearer now.

    With all these explanations, I’ve managed to resolve most of my problems.

    But, it seems that it still has a bug with footnotes in MMD 6.2.2 (not in MMD 5.4.0)
    Are the footnote and bibliographic citation still in MMD6:
    [^footnote]
    [#citation]

    I hadn’t seen anything about that in the quick start guide.

    So, When you have a paragraph and one footnote in the paragraph, after compilation of MMD6, the latex code footnote is ok:

    Alors que l’important vaisseau faisait lentement route vers l’entrée du port, une rafale de vent l’atteignit\footnote{Naufrage}.

    Le \emph{Vasa} se mit à gîter, puis se redressa. Une deuxième rafale coucha le vaisseau sur son flanc. L’eau s’engouffra dans les sabords ouverts. Le vaisseau coula, entraînant avec lui entre 30 et 50 des 150 membres d’équipage.\footnote{Naufrage}

     
    But when you have a paragraph with several footnotes in the paragraph, the first latex code footnote is ok, but not the following footnote code. It appears a line break:

    Alors que l’important vaisseau faisait lentement route vers l’entrée du port, une rafale de vent l’atteignit\footnote{Naufrage}. Le \emph{Vasa} se mit à gîter, puis se redressa. Une deuxième rafale coucha le vaisseau sur son flanc. L’eau s’engouffra dans les sabords ouverts. Le vaisseau coula, entraînant avec lui entre 30 et 50 des 150 membres d’équipage.\footnote{

    Naufrage} Alors que l’important vaisseau faisait lentement route vers l’entrée du port, une rafale de vent l’atteignit\footnote{

    Naufrage}. Le \emph{Vasa} se mit à gîter, puis se redressa. Une deuxième rafale coucha le vaisseau sur son flanc. L’eau s’engouffra dans les sabords ouverts. Le vaisseau coula, entraînant avec lui entre 30 et 50 des 150 membres d’équipage.\footnote{

    Naufrage}

    So can you help me with that?

    Thank you
    Guillaume

  22. Support Staff 18 Posted by fletcher on 17 Nov, 2017 01:44 PM

    fletcher's Avatar

    Your English is better than my French... ;)

    While there are probably bugs in MMD 6, it has been out and very
    thoroughly tested for over 6 months. So keep in mind that any bugs are
    likely to be subtle.

    I see your LaTeX, but I don't see the MMD source. Show me the MMD you
    are using, the LaTeX you get, and the LaTeX you expect to see. I can
    take a look for the problem.

    Fletcher

    PS> Depending on what sort of writing you do, if you use MMD a lot, you
    might want to check out my MMD text editor -- MultiMarkdown Composer.

    http://multimarkdown.com/composer4/

    It is entirely focused on MultiMarkdown, and is free to try out from the
    Mac App Store. It will always have the most recent MMD built-in.

  23. 19 Posted by Guillaume Marti... on 17 Nov, 2017 02:11 PM

    Guillaume Martins's Avatar

    Here is it. Bellow the screen print.

    Original MMD:

    Latex I have:

    Pdf I have:

    Latex I should have:

    Pdf I should have:

    Guillaume

  24. Support Staff 20 Posted by fletcher on 17 Nov, 2017 02:13 PM

    fletcher's Avatar

    I'm sorry -- please send the MMD in text form instead of PNG so I can
    experiment.

    Thank you,

    F-

  25. 21 Posted by Guillaume Marti... on 17 Nov, 2017 02:19 PM

    Guillaume Martins's Avatar

    Here it is.

  26. Support Staff 22 Posted by fletcher on 17 Nov, 2017 02:57 PM

    fletcher's Avatar

    My apologies -- you are correct!

    After the first footnote was processed, the flag was not reset to
    indicate that blank lines should *not* be added before a paragraph.

    I have pushed a fix to the source code in Github, and it will be
    included in the next version. I also added some tests to the test suite
    to check multiple footnotes in single paragraphs for future reference as
    well.

    Thank you!

    Fletcher

  27. 23 Posted by Guillaume Marti... on 17 Nov, 2017 03:20 PM

    Guillaume Martins's Avatar

    You’re welcome!
    Even if Scrivener MMD and Latex give me headache, their association is really good when it’s work!

    Guillaume

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac