Critical Markup and Latex

Luca Ferrero's Avatar

Luca Ferrero

15 Sep, 2016 03:50 PM

Hello Fletcher,

I just installed MMD composer 2.9 and when I export a file to .tex the critical markup are not stripped away from the .tex file as it happened before. Is this a known problem with the new version? This is a big deal for users like me, since I have tons of comments in my drafts that I isolate with the critical markup and it would be daunting to go into the tex file to remove all of them manually.

Thanks for your help

Luca

  1. 1 Posted by Luca Ferrero on 15 Sep, 2016 11:59 PM

    Luca Ferrero's Avatar

    I just wanted to add that when I revert back to 2.8 the problem does no arise, so it is really a problem with 2.9

  2. Support Staff 2 Posted by fletcher on 16 Sep, 2016 12:02 AM

    fletcher's Avatar

    What mode for CriticMarkup do you have selected? Original
    version/Changed version/Disabled/Highlight differences?

    Sounds like you want Changed version.

    Fletcher

  3. Support Staff 3 Posted by fletcher on 16 Sep, 2016 12:07 AM

    fletcher's Avatar

    I just checked and you're right. This is a change from 2.8.

    I had to rewrite some of the printing code because of changes in Mac OS.
      I used some of the code from 3.0 beta (which works), but there was a
    slight difference in the way the two version work which gave the preview
    settings more control in 2.9.

    I'll look at this, but I do recommend that everyone using v2 switch to
    the beta for v3 (and have for quite a while.)

    http://support.multimarkdown.com/kb/future-plans/where-can-i-download-the-beta-for-v3

    Fletcher

  4. 4 Posted by Luca Ferrero on 17 Sep, 2016 12:06 AM

    Luca Ferrero's Avatar

    Thanks Fletcher. Unfortunately, installing 3.0 has not helped. Actually I now have the problem even when I re-install 2.8. I did a complete uninstall of 2.9, then re-installed and then installed 3.0 and the problem persists. Any idea what I need to fix in the installation/disinstallation?

  5. Support Staff 5 Posted by fletcher on 19 Sep, 2016 02:36 AM

    fletcher's Avatar

    Other than your preferences, there is no "cross-talk" between versions
    of Composer. Check your prefs and menu bars for CriticMarkup related
    settings and set everything the way you want.

    You can also delete your preferences, but you will need to reboot your
    machine to make sure this "sticks" -- OS X has made it harder to change
    preferences by hand over the last few years.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

04 Aug, 2017 10:19 PM
31 Jul, 2017 11:21 PM
31 Jul, 2017 11:02 PM
27 Jul, 2017 12:22 AM
08 May, 2017 07:08 PM

Recent Articles