Basis Header Level from MMD to Latex

Daniel's Avatar

Daniel

06 Aug, 2016 11:55 AM

Hey there,
not so sure if I am just too stupid for this, but I'll just ask.. ;)
I am using Scrivener (in the latest version 1.9.6) to write a thesis and have been very happy with the MMD>Latex output. But I just found out, that the basis level conversion doesn't work as I want it to.. In the standard configuration of the output, it makes \part dividers of the highest level of my manuscript. I need \chapters instead, but adding a MMD-Metadata output option in Scrivener doesn't change anything besides adding for example a \def\basis-headerlevel{3} in the first line of my latex-file. I couldn't find anything about this as a latex command, so I think it is a problem of the MMD-conversion?!
Thanks in advance..
Daniel

  1. 1 Posted by Daniel on 06 Aug, 2016 01:47 PM

    Daniel's Avatar

    Ok.. so by looking through the forums of Scrivener I found kind of a workaround: http://disq.us/p/w06yrj
    It's more like a trick of adding another # to the chapter titles from Scrivener and it seems that the mmd-conversion works this way..
    But shouldn't the normal way work as well?! So if I have a chapter name with only one # and the basis header level is 2, the conversion should add another #?!

  2. Support Staff 2 Posted by fletcher on 06 Aug, 2016 01:59 PM

    fletcher's Avatar

    Daniel,

    It's "Base Header Level", not "basis".

    http://fletcher.github.io/MultiMarkdown-5/metadata.html#baseheaderlevel

    There are also specific metadata keys for certain output formats if you
    need different settings for LaTeX, HTML, etc.

    Hope this helps!

    Fletcher

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac