Text files written in English opening in MultiMarkdown Composer as an Asian language—help?

ryanprandall's Avatar


01 Jun, 2014 12:41 AM

I'm having an odd issue where files (written in English) occasionally open in MMD Composer as an Asian language. When I open the same file in TextWrangler it opens appropriately, i.e. in English. If it somehow helps, the language appears to be Chinese with a few Sanskrit characters occasionally mixed in.

Is there a setting somewhere in MultiMarkdown Composer that I can't find that would allow me to control this? If not, should I report it as a bug?


  1. Support Staff 1 Posted by fletcher on 01 Jun, 2014 12:45 AM

    fletcher's Avatar

    Feel free to send me the file and I'll take a look. But that is *almost* guaranteed to be a problem with the file's encoding.


    Sent from my iPhone

  2. 2 Posted by ryanprandall on 01 Jun, 2014 02:35 AM

    ryanprandall's Avatar

    Hi Fletcher,

    I've attached one of the affected files. What's strange is that I'm
    downloading both affected and unaffected files from the same place—an
    institutional instance of Box—so I'd expect them to all be encoded in the
    same way, or to have similar problems.

    So far this mixup has happened with probably about 15 of 200 files.

    I know embarrassingly little about how to check what was selected for
    encoding on the files, so any help/guidance is appreciated.


  3. Support Staff 3 Posted by fletcher on 01 Jun, 2014 07:10 AM

    fletcher's Avatar


    This file opened for me in Composer just fine. It's UTF-8 encoded. If
    you open it as UTF-16, it appears to be in Japanese or something like that.

    TextWrangler has always been useful for me for verifying the
    encoding/line endings/etc. of text files.


  4. 4 Posted by ryanprandall on 01 Jun, 2014 05:20 PM

    ryanprandall's Avatar


    Is there a way to control whether Composer opens it as UTF-8 or UTF-16? I
    don't remember changing anything to tell it to open files as UTF-16 and
    haven't been able to find any relevant settings.

    I can keep reverting to TextWrangler when necessary; it'd just be more
    pleasant to have these all open as UTF-8 in Composer.

    Thanks again!


  5. Support Staff 5 Posted by fletcher on 01 Jun, 2014 07:45 PM

    fletcher's Avatar

    Composer opens the file based on the encoding specified in the file. I've never had a problem with files being opened with the wrong encoding in all my testing.

    You probably need to verify how the files are being created.

    I'm happy to look at others but the first you sent opens appropriately.


    Sent from my iPhone

  6. 6 Posted by ryanprandall on 01 Jun, 2014 08:14 PM

    ryanprandall's Avatar

    Here's a screenshot of how it looks in Composer 2.6.9 when I open that
    file, straight after downloading the attachment from my outbox.

    Is there something I could have done with my setup that makes it not open
    appropriately for me, even though it opens appropriately for you?

    I'm on 10.7.5 if that might somehow affect this.


  7. Support Staff 7 Posted by fletcher on 02 Jun, 2014 12:03 AM

    fletcher's Avatar

    Zip the file before sending it to me. Maybe what you sent me wasn't
    what's actually on your computer.

    What sort of encoding does TextWrangler say the file is in?

  8. 8 Posted by ryanprandall on 07 Jun, 2014 01:12 AM

    ryanprandall's Avatar

    Hi again Fletcher,

    Here's a zip of the file, made by using "Compress" in the control+click
    menu (if that might matter).

    If I'm looking in the right places, TextWrangler says it's "Western (Mac OS
    Roman)" with "Windows (CRLF)" endings.

    Thanks again for looking at this!


  9. 9 Posted by ryanprandall on 07 Jun, 2014 01:25 AM

    ryanprandall's Avatar

    Poking around TextWrangler's preferences some more, I realized it's set to
    guess Western (Mac OS Roman) if it can't determine the encoding.

    So maybe there's something wrong with the encoding of the affected files,
    and TextWrangler and Composer are making different guesses?

    - Ryan

  10. Support Staff 10 Posted by fletcher on 07 Jun, 2014 01:33 AM

    fletcher's Avatar

    This file did open in "Chinese" in Composer on my machine. Also in Roman in Text Wrangler, but if you look carefully, you'll realize that's not quite right either --

    opinion trends in Northeast Asia. Weπve collected an

    If you delete that errant character (what I presume was an apostrophe), it opens properly. Did this document come from copy/pasting via Microsoft Word?

    Roman encoding (to my knowledge) is hardly ever used -- it's an old format for Mac documents, but unicode would be the standard now.

    Something is "wonky" with whatever is generating your files -- I would approach it from that end.


    Fletcher T. Penney
    [email blocked]

  11. 11 Posted by ryanprandall on 07 Jun, 2014 02:37 AM

    ryanprandall's Avatar

    Okay, thanks.

    Unfortunately, I don't have any control over the generation process of
    these, and I'm not even sure how they were made. I'm further down the line,
    doing different things with them. I'd suspect that Word was in the process
    somewhere, though.

    But knowing there's nothing I can do to make the oddness disappear does
    help me resign myself to using TextWrangler, which doesn't have autopairing
    for brackets as far as I can tell. It's amazing how useful that feature
    becomes when you're tasked with inserting brackets for hours on end in
    order to hide information from another script.

    Thanks again for taking the time to look at these!


  12. Support Staff 12 Posted by fletcher on 07 Jun, 2014 11:58 AM

    fletcher's Avatar

    Depending on what your plans are for the documents, it may be best to let someone "up the line" know that their document workflow needs some tweaking. These are the sorts of issues that tend to cause difficult to debug problems down the line (as you've discovered.)

    If you use the terminal and type "less whatever.txt" you can sometimes easily identify the "wonky" characters. My guess is that you will find that most often it is something like a "pretty" apostrophe or quotation mark, that most often came from Word or something like that.

    You could probably write a script to strip out those characters (and replace them with something like "FIXTHIS" so you can identify what needs to be fixed).

    Even if you use TextWrangler, the file is still incorrect and you'll have bizarre looking characters until you fix them. Once they're fixed, you can go back to using Composer.

    But obviously the choice is yours… ;)


    Fletcher T. Penney
    [email blocked]

  13. 13 Posted by ryanprandall on 14 Jun, 2014 10:22 PM

    ryanprandall's Avatar

    Just wanted to thank you for pointing out that the file's encoding would
    still be wrong, even though I was able to read the content in TextWrangler.

    Should anyone else contact you with a similar issue, I've found that if I
    just change the encoding via TextWrangler (in 4.5.9 on my machine it's the
    bottom frame, second selector menu in from the left) and then re-save the
    file, it'll open up correctly in Composer.

    As for my own situation, I've asked and never heard back about how these
    files were created. But at least your comment helped me figure out what to
    do so that the text mining script should reliably run with all these—so
    again, many thanks!


  14. Support Staff 14 Posted by fletcher on 14 Jun, 2014 10:23 PM

    fletcher's Avatar

    No worries -- Glad you've got a working fix!


Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Feb, 2018 10:29 PM
17 Nov, 2017 03:20 PM
19 Sep, 2017 02:19 PM
06 Sep, 2017 07:18 AM
31 Jul, 2017 11:21 PM

Recent Articles