MMD 4.4 Crash on Mac OS X 10.7.5

rwcope2's Avatar

rwcope2

26 Nov, 2013 02:50 AM

I just installed MMD 4.4 using the installer, and now when I invoke multimarkdown, I get Illegal instruction: 4 as the result. The console messages show this:

11/25/13 9:28:45.228 PM ReportCrash: Failed to create CSSymbolicatorRef for bash[18994]
11/25/13 9:28:45.338 PM ReportCrash: Failed to create dSYM-less CSSymbolicatorRef for bash[18994]
11/25/13 9:28:45.658 PM ReportCrash: Saved crash report for bash[18994] version ??? (???) to /Users/rob/Library/Logs/DiagnosticReports/bash_2013-11-25-212845_joebob.crash

The contents of the crash report are enclosed.

I tried removing the binaries in /usr/local/bin and running the installer again, but it didn't make a difference.

Any advice would be greatly appreciated.

Thanks,
Rob

  1. Support Staff 1 Posted by fletcher on 27 Nov, 2013 01:51 AM

    fletcher's Avatar

    Rob,

    Thanks for writing in.

    The binary version of MMD included in the installer was compiled for modern hardware/software machines. It takes extra steps to compile for older versions of the Mac OS, or for older machines (e.g. 32-bit machines or PPC).

    I'll try to work out a workflow that allows a single binary to run across more machines, but the surefire way to run on older versions of the OS or older hardware, is to compile MMD for yourself (either by downloading source from github, or through something like homebrew). It should compile for any version of Mac OS (10+), and on any hardware. But the individual binaries won't necessarily run across all versions of hardware/software.

    Hope this helps!

    F-

  2. fletcher closed this discussion on 27 Nov, 2013 01:51 AM.

  3. rwcope2 re-opened this discussion on 30 Nov, 2013 03:48 AM

  4. 2 Posted by rwcope2 on 30 Nov, 2013 03:48 AM

    rwcope2's Avatar

    The 4.4.2 update solved the problem.

    Thank you very much.

    Rob

  5. Support Staff 3 Posted by fletcher on 01 Dec, 2013 01:17 PM

    fletcher's Avatar

    You're welcome. Glad it's working for you.

    F-

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

08 Dec, 2018 08:58 PM
14 Nov, 2018 04:54 AM
09 Nov, 2018 04:49 PM
09 Nov, 2018 04:46 PM
09 Nov, 2018 04:44 PM

Recent Articles