Trouble compiling mmd from source on Mojave

glen's Avatar

glen

13 Jul, 2019 08:23 PM

I am having trouble compiling mmd from source on a Mac running macOS Mojave 10.14.5.

The short version is: the error I receive when trying build is:

ld: library not found for -lgcc_s.10.4

The long version:

I am new to this so hopefully there is enough info here for troubleshooting:

  1. Installed Xcode.app (v.10.2.1) from the App Store.
  2. Launched Xcode and agreed to the terms.
  3. Installed CommandLine Tools and confirmed installation.
    xcode-select --install xcode-select: error: command line tools are already installed, use "Software Update" to install updates
  4. Downloaded: MultiMarkdown-6-master.zip, unzipped, and put in my home directory.
  5. From Terminal.app I cd to ~/MultiMarkdown-6-master, entered "make"; everything seemed to configure without error.
  6. Then cd to ~/MultiMarkdown-6-master/build/ and entered "make".
  7. Compiling seemed to run smoothly to 97% and then the following error was reported:
    [100%] Linking C executable multimarkdown ld: library not found for -lgcc_s.10.4 clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: *** [multimarkdown] Error 1 make[1]: *** [CMakeFiles/multimarkdown.dir/all] Error 2 make: *** [all] Error 2

I tried following advice based on what appeared to be a similar problem based on my searching here and here. But I keep ending up at the error indicated in step 7.

Thanks for any help you may have.

  1. glen closed this discussion on 14 Jul, 2019 06:41 AM.

  2. fletcher re-opened this discussion on 14 Jul, 2019 02:15 PM

  3. Support Staff 1 Posted by fletcher on 14 Jul, 2019 02:17 PM

    fletcher's Avatar

    I'm assuming you closed this because you figured it out, but just in case.

    You can use the develop branch to compile on more recent versions of macOS. Once I release the next official version, you can also use master.

    Alternatively, modify CMakeLists.txt and change the CMAKE_OSX_DEPLOYMENT_TARGET from 10.4 to 10.6 or later.

    Fletcher

  4. 2 Posted by glen on 15 Jul, 2019 03:54 AM

    glen's Avatar

    Yeah, I just figured it out late the other day. First I had to make sure /usr/local/lib was in my path in my .bash_profile. Second, forming the symbolic link between libgcc_s.10.4.dylib to /usr/lib/libSystem.B.dylb did the trick as described here. That did the trick. I'm not completely sure what I did there ... but it worked. Thanks for the other solutions.

  5. Support Staff 3 Posted by fletcher on 15 Jul, 2019 12:27 PM

    fletcher's Avatar

    That fix may work, but is technically not a good idea in general. In this instance, though, it shouldn't cause any problems.

  6. fletcher closed this discussion on 15 Jul, 2019 12:27 PM.

  7. glen re-opened this discussion on 19 Jul, 2019 06:50 PM

  8. glen closed this discussion on 20 Jul, 2019 01:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac