brew upgrade multimardown fails

Frode Weierud's Avatar

Frode Weierud

02 Apr, 2019 01:50 PM

Hello,
I have just tried to upgrade my installation of Mulitmarkdown using brew. It fails with the following errors:
bash-3.2$ brew upgrade multimarkdown
==> Upgrading 1 outdated package:
multimarkdown HEAD-193c09a -> HEAD-193c09a
==> Upgrading multimarkdown
==> Cloning https://github.com/fletcher/MultiMarkdown-6.git
Updating /Users/admin/Library/Caches/Homebrew/multimarkdown--git
==> Checking out branch master
Already on 'master'
Your branch is up to date with 'origin/master'.
HEAD is now at 1e633b8 Merge pull request #151 from fletcher/revert-148-convenience-script-PATH
==> make release
==> make
Last 15 lines from /Users/admin/Library/Logs/Homebrew/multimarkdown/02.make:
  "_stdin_buffer", referenced from:
      _main in main.c.o
  "_token_pool_drain", referenced from:
      _main in main.c.o
  "_token_pool_free", referenced from:
      _main in main.c.o
  "_token_pool_init", referenced from:
      _main in main.c.o
  "_unzip_data_to_path", referenced from:
      _main in main.c.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [multimarkdown] Error 1
make[1]: *** [CMakeFiles/multimarkdown.dir/all] Error 2
make: *** [all] Error 2

READ THIS: https://docs.brew.sh/Troubleshooting

This is possibly a Homebrew problem, however all my other packages upgraded OK so I thought I would ask here first.
To me it seems that some libraries or defines are missing. I have installed gettext, glib and pkg-config and the Xcode command like utilities are in place. Here is my Homebrew config:
bash-3.2$ brew config
HOMEBREW_VERSION: 2.0.6
ORIGIN: https://github.com/Homebrew/brew.git
HEAD: 649d1427f5fe41323c436608f5c21513f8f34f71
Last commit: 8 days ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: f35214c3dbffe0ffe3f62978b1c3072a9352cdba
Core tap last commit: 81 minutes ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_LOGS: /Users/admin/Library/Logs/Homebrew
CPU: quad-core 64-bit kabylake
Homebrew Ruby: 2.3.7 => /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby
Clang: 10.0 build 1000
Git: 2.21.0 => /usr/local/bin/git
Curl: 7.54.0 => /usr/bin/curl
macOS: 10.13.6-x86_64
CLT: 10.1.0.0.1.1539992718
Xcode: 10.1

Do you know what may be the problem?
Best wishes,
Frode

  1. 1 Posted by Frode Weierud on 02 Apr, 2019 07:16 PM

    Frode Weierud's Avatar

    I have run brew gist-logs multimarkdown and the resulting gist is here:
    https://gist.github.com/CCRMaster/f02ea72bfa4bfd5ce7674dbc6503befc
    This gives more detailed information.
    Regards,
    Frode

  2. Support Staff 2 Posted by fletcher on 02 Apr, 2019 07:22 PM

    fletcher's Avatar

    Frode,

    Sorry you're having trouble with homebrew. You'll have to check with the maintainer of the homebrew MMD formula. I tried submitting a new one a few years ago when I released MMD v6, but they wouldn't allow me to have two separate formulas (v5 and v6). Someone else must have updated the main MMD formula to v6.

    It compiles fine for me, and also on Travis, as you can see from the github homepage at the top of the README...

    I'm happy to help if I can, but I don't have time right now to troubleshoot homebrew myself.

    Fletcher

  3. 3 Posted by Frode Weierud on 02 Apr, 2019 07:28 PM

    Frode Weierud's Avatar

    Hello Fletcher,

    Many thanks for the very quick reply. I understand there might be some problem with the formula for v6. I have already created an issue on Homebrew/homebrew-core. I will let you know if there is somebody there that has a solution to this problem.

    Best wishes,
    Frode

    Frode Weierud Phone: +47 66785801
    Bjerkealleen 17 Mobil: +47 97036715
    1385 Asker E-mail: [email blocked],
    NORWAY [email blocked]
                                            WWW: http://cryptocellar.org

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac